题目描述:
-
输入一个正整数数组,把数组里所有数字拼接起来排成一个数,打印能拼接出的所有数字中最小的一个。例如输入数组{3,32,321},则打印出这三个数字能排成的最小数字为321323。
输入:
-
输入可能包含多个测试样例。 对于每个测试案例,输入的第一行为一个整数m (1<=m <=100)代表输入的正整数的个数。 输入的第二行包括m个正整数,其中每个正整数不超过10000000。
输出:
-
对应每个测试案例, 输出m个数字能排成的最小数字。
样例输入:
-
3
23 13 6
2
23456 56
样例输出:
-
13236
2345656
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
bool cmp(const string &a,const string &b){
string s1 = a + b;
string s2 = b + a;
return s1 < s2;
}
int main(int argc, char const *argv[])
{
int m;
string s[102];
while(scanf("%d",&m) != EOF){
for(int i = 0;i < m;i++)
cin >> s[i];
sort(s,s + m,cmp);
for(int i = 0;i < m;i++)
cout << s[i];
cout << endl;
}
return 0;
}
|
|