2115 C Looooops 拓展欧几里得

论坛 期权论坛 脚本     
已经匿名di用户   2022-5-29 19:06   1671   0
C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8812 Accepted: 1969

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2 k) modulo 2 k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2 k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER
#include<iostream>
#include<cstdio>
using namespace std;
__int64 exgcd(__int64 a,__int64 b,__int64 &x,__int64 &y)
{
if(b==0)
{
x=1,y=0;
return a;
}
__int64 r=exgcd(b,a%b,x,y);
__int64 t=x;
x=y;
y=t-a/b*y;
return r;
}
int main()
{
__int64 a,b,c,k;
while(scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&k)==4)
{
if(a==0&&b==0&&c==0&&k==0) break;
__int64 n=c,m=(__int64)1<<k,v=b-a,x,y;//m=(__int64)1<<k 不能写成(__int64)(1<<k),否则越界
__int64 r=exgcd(n,m,x,y);//nx = v(mod m)
if(v%r)
{
printf("FOREVER/n");
continue;
}
x=x*(v/r)%m+m;
__int64 g=m/r;
x=((x%g)+g)%g;
printf("%I64d/n",x);
}
return 0;
}
分享到 :
0 人收藏
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

积分:81
帖子:4969
精华:0
期权论坛 期权论坛
发布
内容

下载期权论坛手机APP