华为机试—从5个人中选取2个人作为礼仪

论坛 期权论坛 编程之家     
选择匿名的用户   2021-6-2 20:59   2924   0

要从5个人中选取2个人作为礼仪,其中每个人的身高范围为160-190,要求2个人的身高差值最小

(如果差值相同的话,选取其中最高的两人),以升序输出两个人的身高。


Sample input: 161 189 167 172 188

Sample output: 188 189


#include <stdio.h>
#include <stdlib.h>

int compare(const void *p,const void *q){
 return *(int *)p-*(int *)q;
}

int main()
{
 int n,i=0,a[100];
 scanf("%d",&n);
 while(getchar()!='\n'){
  a[i++]=n;
  scanf("%d",&n);
 }
 a[i++]=n;

 qsort(a,i,sizeof(int),compare);

 int ans=a[1]-a[0],k;
 for(int j=1;j<i-1;j++)
 {
  if(ans>=a[j+1]-a[j])
  {
   ans=a[j+1]-a[j];
   k=j;
  }
 }

 printf("%d %d\n",a[k],a[k+1]);
  
 return 0;
}


测试结果,可能想的不周全,欢迎查漏补缺:



分享到 :
0 人收藏
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

积分:3875789
帖子:775174
精华:0
期权论坛 期权论坛
发布
内容

下载期权论坛手机APP