浙大pat1050题解

论坛 期权论坛 编程之家     
选择匿名的用户   2021-6-2 16:09   897   0

1050. String Subtraction (20)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.




#include <iostream>
#include <string>
#include <vector>
#include <queue>
#include <string.h>
#include <algorithm>
using namespace std;
string s1,s2;
bool mycompare(char ch)
{
string::iterator it;
for(it= s2.begin();it!=s2.end();it++)
{
if(ch == *it)
return true;
}
return false;
}
int main()
{

getline(cin,s1);
getline(cin,s2);
sort(s2.begin(),s2.end());
s2.erase(unique(s2.begin(),s2.end()),s2.end());
s1.resize(remove_if(s1.begin(),s1.end(),mycompare)-s1.begin());
cout<< s1<<endl;

return 0;
}

转载于:https://www.cnblogs.com/luxiao/p/pat005.html

分享到 :
0 人收藏
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

积分:3875789
帖子:775174
精华:0
期权论坛 期权论坛
发布
内容

下载期权论坛手机APP