poj 1207 The 3n + 1 problem

论坛 期权论坛 脚本     
已经匿名di用户   2022-5-29 19:11   782   0
The 3n + 1 problem
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 57903 Accepted: 18478

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:
 

  1.    input n



  2.    print n



  3.    if n = 1 then STOP



  4.       if n is odd then   n <-- 3n+1



  5.       else   n <-- n/2



  6.    GOTO 2




Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.


Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174
 
题目大意:
这个题目的意思是让我们求最大的循环次数,首先会给我们两个数i和j,求这区间的所有数字按照题目中的规则循环最多循环多少次
循环的规则是:当n为奇数的时候执行n=3n+1,如果n为偶数执行n=n/2,直到n=1是停止循环,例如n=22,按照规则循环之后就是这样的
22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 ,所以大家就知道怎么做了。

题目解析:
这个题是最简单的题了,只需要每一个数字都去判断混换多少次,把最大的那个输出就可以了,其他的就不多说什么了,直接看代码
就好啦。

代码:
#include<iostream>
using namespace std;
int main()
{
    int i,j,k,cnt,max_cnt,temp;
    while(cin>>i>>j)
    {
        max_cnt=1;
        for(k=(i<j?i:j);k<=(i>j?i:j);k++)
        {
            cnt=1;
            temp=k;
            while(temp!=1)
            {
                if(temp%2==1)
                    temp=3*temp+1;
                else
                    temp=temp/2;
                    cnt++;
                    max_cnt=cnt>max_cnt?cnt:max_cnt;
            }
        }
        cout<<i<<" "<<j<<" "<<max_cnt<<endl;
    }
    return 0;
}
分享到 :
0 人收藏
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

积分:81
帖子:4969
精华:0
期权论坛 期权论坛
发布
内容

下载期权论坛手机APP